Προσπέλαση πίνακα

ΠΡΟΓΡΑΜΜΑ εμφάνιση_στοιχείων_πίνακα
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[5, 4], ι, κ
  ΧΑΡΑΚΤΗΡΕΣ: επιλ
ΑΡΧΗ
  Α[1, 1] <- 4
  Α[2, 1] <- 5
  Α[3, 1] <- 10
  Α[4, 1] <- 15
  Α[5, 1] <- 19
  Α[1, 2] <- 5
  Α[2, 2] <- 5
  Α[3, 2] <- 4
  Α[4, 2] <- 5
  Α[5, 2] <- 15
  Α[1, 3] <- 1
  Α[2, 3] <- 6
  Α[3, 3] <- 9
  Α[4, 3] <- 5
  Α[5, 3] <- 5
  Α[1, 4] <- 7
  Α[2, 4] <- 4
  Α[3, 4] <- 8
  Α[4, 4] <- 5
  Α[5, 4] <- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΛΕΣΕ ΕμφΓρΣτ(Α) 
    ΓΡΑΨΕ "1. Εμφάνιση στοιχείων ανά γραμμή"
    ΓΡΑΨΕ "2. Εμφάνιση στοιχείων ανά στήλη"
    ΓΡΑΨΕ "3. Εμφάνιση στοιχείων ανά  γραμμή βουστροφηδόν"
    ΓΡΑΨΕ "4. Εμφάνιση στοιχείων ανά  στήλη βουστροφηδόν"
    ΓΡΑΨΕ "5. Εμφάνιση στοιχείων ανά  γραμμή ελικηδόν"
    ΓΡΑΨΕ "6. Έξοδος"
    ΓΡΑΨΕ "Πληκτρολόγησε την επιλογή σου:", " "
    ΔΙΑΒΑΣΕ επιλ
    ΕΠΙΛΕΞΕ επιλ
      ΠΕΡΙΠΤΩΣΗ "1"
        ΚΑΛΕΣΕ ΕμφΓρΣτ(Α) 
      ΠΕΡΙΠΤΩΣΗ "2"
        ΚΑΛΕΣΕ ΕμφΣτΓρ(Α) 
      ΠΕΡΙΠΤΩΣΗ "3"
        ΚΑΛΕΣΕ ΕμφΓρΒουστρ(Α) 
      ΠΕΡΙΠΤΩΣΗ "4"
        ΚΑΛΕΣΕ ΕμφΣτΒουστρ(Α) 
      ΠΕΡΙΠΤΩΣΗ "5"
        ΚΑΛΕΣΕ Ελικηδον(Α) 
    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ επιλ = "6"
  !Ο όρος ελικηδόν είναι αρχαίο ελληνικό επίρρημα που σημαίνει κίνηση της έλικας
!Βουστροφηδόν είναι τρόπος γραφής με εναλλασσόμενη φορά. Ο όρος χρησιμοποιήθηκε αρχικά από τους αρχαίους Έλληνες για να περιγράψουν την ιδιάζουσα αρχαϊκή ελληνική γραφή

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
ΔΙΑΔΙΚΑΣΙΑ ΕμφΓρΣτ(πιν) 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πιν[5, 4], μ, ν
ΑΡΧΗ
  ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 4
      ΓΡΑΨΕ πιν[μ, ν], ",", " "
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ""
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ 

ΔΙΑΔΙΚΑΣΙΑ ΕμφΣτΓρ(πιν) 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πιν[5, 4], μ, ν
ΑΡΧΗ
  ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 5
      ΓΡΑΨΕ πιν[ν, μ], ",", " "
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ""
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ ΕμφΓρΒουστρ(πιν) 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πιν[5, 4], μ, ν, στηλη, μεταβολη
ΑΡΧΗ
  ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 5
    ΑΝ μ mod 2 = 1 ΤΟΤΕ
      στηλη <- 1
      μεταβολη <- 1
    ΑΛΛΙΩΣ
      στηλη <- 4
      μεταβολη <- -1
    ΤΕΛΟΣ_ΑΝ
    ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 4
      ΓΡΑΨΕ πιν[μ, στηλη], ",", " "
      στηλη <- στηλη + μεταβολη
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ""
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ ΕμφΣτΒουστρ(πιν) 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πιν[5, 4], μ, ν, γραμμη, μεταβολη
ΑΡΧΗ
  γραμμη <- 0
  μεταβολη <- -1
  ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 4
    μεταβολη <- μεταβολη*-1
    γραμμη <- γραμμη + μεταβολη
    ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 5
      ΓΡΑΨΕ πιν[γραμμη, μ], ",", " "
      γραμμη <- γραμμη + μεταβολη
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ""
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Ελικηδον(πιν) 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πιν[5, 4], γρ, στ, Αοριο_γραμμης, Αοριο_στηλης, Βοριο_γραμμης, 
  & Βοριο_στηλης, μεταβγρ, μεταβστ, μ
ΑΡΧΗ
  Αοριο_γραμμης <- 1
  Αοριο_στηλης <- 1
  Βοριο_γραμμης <- 5
  Βοριο_στηλης <- 4
  γρ <- 1
  στ <- 1
  μεταβγρ <- 0
  μεταβστ <- 1
  ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ γρ = Βοριο_γραμμης ΚΑΙ μεταβγρ = 1 ΤΟΤΕ
      μεταβγρ <- 0
      μεταβστ <- -1
    ΑΛΛΙΩΣ_ΑΝ γρ = Αοριο_γραμμης ΚΑΙ μεταβγρ = -1 ΤΟΤΕ
      μεταβγρ <- 0
      μεταβστ <- 1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ στ = Βοριο_στηλης ΚΑΙ μεταβστ = 1 ΤΟΤΕ
      μεταβστ <- 0
      μεταβγρ <- 1
    ΑΛΛΙΩΣ_ΑΝ στ = Αοριο_στηλης ΚΑΙ μεταβστ = -1 ΤΟΤΕ
      μεταβστ <- 0
      μεταβγρ <- -1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ μεταβγρ = 0 ΚΑΙ μεταβστ = 0 ΤΟΤΕ
      ΑΝ στ = Βοριο_στηλης ΤΟΤΕ
        Βοριο_στηλης <- Βοριο_στηλης - 1
        Αοριο_γραμμης <- Αοριο_γραμμης + 1
        μεταβστ <- -1
        μεταβγρ <- 0
      ΤΕΛΟΣ_ΑΝ
      ΑΝ γρ = Αοριο_γραμμης ΤΟΤΕ
        Βοριο_γραμμης <- Βοριο_γραμμης - 1
        Αοριο_στηλης <- Αοριο_στηλης + 1
        μεταβστ <- 0
        μεταβγρ <- -1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ πιν[γρ, στ], ",", " "
    γρ <- γρ + μεταβγρ
    στ <- στ + μεταβστ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ""
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ