Συχνότητα εμφάνισης στοιχείου σε πίνακα

Το παρακάτω πρόγραμμα βρίσκει το στοιχείο με την μεγαλύτερη συχνότητα εμφάνισης σε ένα δισδιάστατο πίνακα .

ΠΡΟΓΡΑΜΜΑ ευρευση_συχνοτερης_τιμης

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[5, 4], ι, κ, μετρ, αριθμ_εμφ[20, 2], μεγιστ, θεσ_μεγ, δ
  ΛΟΓΙΚΕΣ: υπαρχει
ΑΡΧΗ
  Α[1, 1] <- 4
  Α[2, 1] <- 5
  Α[3, 1] <- 10
  Α[4, 1] <- 15
  Α[5, 1] <- 19
  Α[1, 2] <- 5
  Α[2, 2] <- 5
  Α[3, 2] <- 4
  Α[4, 2] <- 5
  Α[5, 2] <- 15
  Α[1, 3] <- 1
  Α[2, 3] <- 6
  Α[3, 3] <- 9
  Α[4, 3] <- 5
  Α[5, 3] <- 5
  Α[1, 4] <- 7
  Α[2, 4] <- 4
  Α[3, 4] <- 8
  Α[4, 4] <- 5
  Α[5, 4] <- 1
  μετρ <- 0

  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 4
      υπαρχει <- ΨΕΥΔΗΣ
      δ <- 1
      ΟΣΟ (δ <= μετρ) ΚΑΙ ΟΧΙ(υπαρχει) ΕΠΑΝΑΛΑΒΕ
        ΑΝ Α[ι, κ] = αριθμ_εμφ[δ, 1] ΤΟΤΕ
          υπαρχει <- ΑΛΗΘΗΣ
          αριθμ_εμφ[δ, 2] <- αριθμ_εμφ[δ, 2] + 1
        ΤΕΛΟΣ_ΑΝ
        δ <- δ + 1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ ΟΧΙ(υπαρχει) ΤΟΤΕ
        αριθμ_εμφ[δ, 1] <- Α[ι, κ] 
        αριθμ_εμφ[δ, 2] <- 1
        μετρ <- μετρ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  μεγιστ <- αριθμ_εμφ[1, 2] 
  θεσ_μεγ <- 1
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ μετρ
    ΓΡΑΨΕ "Το στοιχείο ", αριθμ_εμφ[ι, 1], " υπάρχει ", αριθμ_εμφ[ι, 2], " φορές"
    ΑΝ αριθμ_εμφ[ι, 2] > μεγιστ ΤΟΤΕ
      μεγιστ <- αριθμ_εμφ[ι, 2] 
      θεσ_μεγ <- ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ "Το στοιχείο που έχει την μεγαλύτερη συχνότητα εμφάνισης ειναι το ", αριθμ_εμφ[θεσ_μεγ, 1], " και υπάρχει ", αριθμ_εμφ[θεσ_μεγ, 2], " φορές"
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ